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Introduction   

Overview  
  

This tutorial describes the basic operation and typical use of BoardModeler Lite.  It is designed for 

first-time users to become familiar with the common commands and to gain experience of using 

BoardModeler Lite in a typical design flow with CADSTAR.   

  

Further Information  
  

For further detailed information on the topics covered in this tutorial, please refer to the on-line help 

provided within the application.  This can be accessed via the Help/Help BoardModeler... menu 

option or by pressing the F1 function key.    

  

For further clarification, the BoardModeler suffix of “Lite” implies that it is aligned with the CADSTAR 

Product suite, whereas BoardModeler (no suffix) is aligned with the Zuken CR-5000 solutions.    

  

Conventions and Terminology Used In This Document  
  

The following conventions and terminology are used throughout the tutorial document  

  

• Commands, menu options or user interface operations are shown using bold italic text, for 

example, Tools>Options  

  

• Names of file system objects (file paths, file names, folder names etc.) are shown in italic  

text surrounded by single quotes, for example, ‘C:\BML_Tutorial_Data\BM\_Project’   

  

• Any values or settings that must be entered into the BoardModeler Lite user interface by 

typing text are shown enclosed in double quotes, for example, “0.5”.  Note that the 

quotation marks should UnotU be entered as part of the text input.  

  
• Throughout this tutorial, the ‘BoardModeler Lite’ application name is usually abbreviated to  

‘BML’.  

  

• This Symbol indicates an HTML link to a demonstration video.  This icon will appear  
frequently throughout the tutorial.  An internet connection is required to see the videos.  
They are best viewed with Internet Explorer (c) 10.0 or newer and Firefox (c) 21.0 or newer.  

   

Software Tools Used By This Tutorial  
  

This self-teach tutorial guide requires the use of the following tools:  

  

• BoardModeler Lite 18.1  

• CADSTAR 2022 or later  
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What is BoardModeler Lite?  

BoardModeler Lite (BML) provides a powerful design environment to bridge the gap between electronic 

(ECAD) and mechanical (MCAD) design.  BML is a tool for use by the PCB designer, to combine the 

twodimensional (2D) board design data and the three-dimensional (3D) mechanical design data in a single 

environment.  It also allows for easy exchange of data between the electronic and mechanical domains.   

  

   Mechanical CAD  CADSTAR  

 

 BoardModeler Lite 

  

BoardModeler Lite addresses the following main functional areas:  

  

• 3D Representations for Electrical and Mechanical Parts  

  

BML provides the functionality to import the 2D CADSTAR PCB design data and 3D mechanical design 

data and to combine it in a single environment.  It is able to display realistic 3D models to represent all 

aspects of the design, such as the board outline, PCB layers, electronic parts mounted on the board and 

a mechanical case or chassis.  This is all presented in a single window and allows the user to view the 

data in 3D, from any required viewpoint.  

  

• Clearance and Collision Checking  

  

BML provides the features to check a design (either interactively or in batch check mode) for collisions 

between components mounted on the board and between the components and board shape and any 

enclosing mechanical constraint (e.g. a case or chassis).  It is also possible to measure sizes of design 

objects and measure the clearances between them.  

  

• Back-annotation of Design Changes from 3D to 2D  

  

BML allows changes made to the component placement in the 3D environment to be passed back to the 

2D CADSTAR PCB design.  This also covers the ability to pass initial board outline shape, critical 

component placement and keep-out or height limitation areas, supplied by the MCAD department, into 

the 2D CADSTAR PCB design.  

  

 All of these areas will be covered in this tutorial.  
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Data File Structure for BoardModeler Lite  

The design data used by BoardModeler Lite is stored in a defined folder structure in the file system on disk.  

The location and naming of these folders is set up in BML on the Project tab of the Tools>Options dialog  

(as shown in the image below).  

  

The location of the Document root folder is set during the software installation process (the default 

location is ‘C:\DOCUMENT’) but this can be changed later through the Tools>Options dialog.  However, 

it is important to note that these locations can only be changed when no Project data is loaded into 

BML.  Also note that if you do not have ‘Administrator’ privileges you will need to first select the Private 

option on the Tools>Options dialog in order to be able to modify the folder paths.  

  

  

Document Root Folder  

  

This is the main folder that contains all design data 

relating to BML.  When this location is defined the 

following four sub-folders will be created automatically 

inside a folder called ‘BM’ in the Document Root Folder.  

  

_Project _Library  

_Interface  

_Resource  

  

Project Root Folder  

  

This folder is used to store data for individual projects 

created in BML.  The default location for this folder is;  

‘<Document Root Folder>\BM\_Project’, although it can 

be changed to a different location of your choice.  

  

Library Root Folder  

  

This is the folder that is used to store the 3D model data 

to be used to represent how the components (parts) will 

be viewed in BML.  The default location for this folder is  

‘<Document Root Folder>\BM\_Library’, although it can 

be changed to a different location of your choice.  

  

Underneath this folder are six separate folders (‘_Parts (Level 1)’ to ‘_Parts (Level 6)’), which allow 3D 

models of up to six different levels of detail to be used to represent each component. The required level of 

detail to use for display can be chosen from within BML.  This will be covered further later in the tutorial.  

  

Save BML project in the same location as the CADSTAR Design  

  

When checked, BML will create a folder (called 'BML') in the same folder as the CADSTAR PCB design 

file.  In that BML folder, it will create the <design_name>.bma file along with a folder called <design_name> 

where is stores all its other files for the project.  

  

 

 

 

 

 

   

http://www.zuken.com/cadstar


For more information visit  www.zuken.com/cadstar  

7 
 

Task 1 - Configuration Set-up for the Tutorial  
  

  

This tutorial expects the design data to be located in a folder called ‘C:\ BML_Tutorial_Data’ and so we will now 

go through the steps necessary to configure BML to access this data.  To begin, ensure that you have extracted 

the tutorial example data from the zip file (‘BML_Tutorial_Data.zip’) supplied with the tutorial into ‘C:\ 

BML_Tutorial_Data’.    

  

Note: If you choose to put the example data in a different location, you will need to substitute all the file paths 

in the following tutorial to match the actual location of the data.  

  

  

Now perform the following steps.  

  

1. Select  All Programs>BoardModeler Lite>BoardModeler from the Windows Start menu.  

BoardModeler Lite will run up.  

  

  

2. From the main menu bar select Tools>Options to 

display the BoardModeler Options dialog and 

ensure the Project tab is active.  

  

  

3. Specify the folder locations as shown in the 

image.  Note that once you have entered the path 

for the Document root folder and clicked [Apply] 

the paths for Project and Library root folders will 

be set automatically.  

  

Note: If you cannot edit these locations, you may 

need to close any open project.  

  

If you do not have ‘Administrator’ account 

privileges on the computer, make sure that you 

select the Private option to enable the folder 

paths to be modified.  

  

The adjacent operations will direct BoardModeler  

Lite to access the folder structure as shown in the  

  

  

The example CADSTAR data which will be used during the rest of this tutorial is located in the  

‘CADSTAR’ folder.   

  

  

4. To keep your BoardModeler design localized to your PCB design folder, check the option circled 

above.  

image  below.   
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In order to make sure that you can match the operations described throughout the following tutorial, ensure 

that the settings on each tab of the Tools>Options dialog are set as shown in the following images.  The 

most important settings are highlighted with a red border.   

  

 
  

6. Select File>Exit to close down BoardModeler Lite  

  

  

  

  

  

      End of task  

  

  
  
  
  
  
  
  
  
  
  
  
  

  
  
  
  
  
  
  
  
  
  
  
  
  

  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  

5.   Click the  Apply   button followed by  Close .   
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Task 2 - Basic Operations – Becoming Familiar with the U.I.  
In this section we will take an initial look at BoardModeler Lite and become familiar with the different areas 

of the user interface and how to perform such common operations as selecting objects in the design or 

changing the view of the design (i.e. rotate, pan and zoom, setting colours etc.)  

  

Start by loading CADSTAR and then opening the Basic Operations workspace (‘BasicOperations.csw’) 

from the ‘C:\BML_Tutorial_Data\CADSTAR\Self Teach’ folder.  

  

End of task  

Note:    If you have changed folder locations in Task 1, the CSW  

files will not operate correctly.   

  
1.   From the CADSTAR Tools menu, select the  Board Modeler ...  

option.  Select OK to  confirm the dialog s   that appear .   
  

Note   If you have already run all or part  : of the tutorial  
before, you may   see two further dialogs prompting for  
permission to overwrite the existing data.  Select  OK   
and   then   Yes   in these dialogs.   

  
  
  

  

  

  

  

  

  

  

  
2.   Set  the options as shown      

  

Select : Top Placement ”   from the pull down list   as  
the name of the CADSTAR l ayer that contains the  
default 2D  component geometries   that will be  
displa yed in 3D with in BML.   
  

Alternatively you can select   Top Silk   or  Top  
Assembly.   
  

3.   S elect [ OK ]   
  

  

BML will first convert the CADSTAR CPA file into the  

necessary files for BML to read.     

BML will then continue to load the design and  create the  

necessary graphics data to be displayed by the  

application.   

The PCB design will be a utomatically opened for display  

in BML and should  look similar to the image on the next  

page.   
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 The User Interface  

  

The different sections of the BML user interface are shown labelled in the image below and you should 

spend a few minutes to acquaint yourself with the different areas and their names.  They will be referred 

to throughout the rest of this tutorial.  

  

 
  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

Project 

  

Browser 

  

Control  
Panel   

Graphics  
Panel   

3 D Model  

Tool bar 
  

Tool bar 

  

Menu bar 

  

Graphics Window   

3 D  Model  
preview   
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Manipulating the Display  

  

Using the Standard Views  

  

BML provides a number of toolbar icons to quickly switch between different, pre-set views on the design.  

These cover the standard 2D views (top, bottom, front, back and both sides) in addition to 3D ‘Isometric’ 

views of the top and bottom of the board.  

  

 

  

1. Hover your mouse cursor over each icon to see the tooltip which describes its function.  Experiment 

with the different toolbar options to see the effect on the graphics display.  Select the top (A-side) 

Isometric option when you have finished, return to the standard 3D view.  

  

 
  

           Orthographic                 Perspective  

  

  
  

Note:   T he same functions are also available from  

the     View > Orthogonal   view   menu if preferred.   
  

  
2.   If you would  rather   see the 3D view as a  

perspective projection (rather than orthographic)  
you may select this  option  from the  
View > Projection   mode menu.   
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 Changing the Scene Rendering Mode  

  

In a similar way, BML provides a set of toolbar icons to quickly switch between different, ‘scene rendering’ 

modes.  These offer ‘Shaded on Wire’, ‘Shaded’ and simple ‘Wireframe’ views.  

  

 

  

  

1. Experiment with the different modes by selecting the icons from the toolbar or from the View / Scene  

rendering menu option.  

  

  

The scene rendering mode chosen will have an impact on how much CPU resource is required to 

manipulate the display (when rotating, panning or zooming, for example) and it will also affect which 

features of the design data can be selected.  These differences are summarised in the following table.  

  

  

Icon  Rendering Mode  Performance  Selection  

  

Shaded on wire  

 

Slow  

(especially with 

large designs)  

All  

 
Shaded  

 

Medium  

Surfaces are 

selectable, but 

not edges  

 
Wireframe  

 

Highest  

No surfaces are 

selectable – only 

edges  

  

  

  

It is also possible to control the rendering mode individually for 

each object in the design (e.g. parts, board, mechanical 

constraint, etc.), and in these cases it is possible to select a 

‘transparent’ rendering mode and a ‘hidden’ mode (where the 

selected object is not displayed at all).  We will return to this 

feature later in the tutorial.  
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You may change the rendering mode for all 

parts in the design with one operation.  At the 

top of the Control Panel in the Graphics 

Window, there is a drop-down list box which 

allows the different rendering modes to be 

selected.  The image to the right shows the 

effect of selecting the ‘Transparent’ mode.  

  

  

       See the effect of the different modes by 

selecting the options from the drop-down 

list in the Control Panel.  When you have 

finished, restore the display by selecting 

the ‘Default’ option from the list.  

  

  

  

Changing the view – Pan, Zoom and Rotate (Orbit)  

  

BML provides a set of toolbar icons to invoke commands to change the view of the design in the graphics 

panel.  These include standard 2D pan and zoom operations, but also a 3D rotate (or ‘orbit’) function.  The 

full list of available commands is listed in the table below.  

  

Note: selecting the Rotate, Zoom, Pan or Frame icons will set a ‘mode’ that will continue to be active until 

another command is selected.  Pick the Select icon  from the top of the 3D Model Toolbar or press the 

‘Esc’ key to cancel these commands.  

  

If you use the Mouse Tool short-cuts instead, then these operations (Rotate, Zoom and Pan) can be used at 

any time (even during the execution of other operations – for example, the Move command) and the tools 

are only active while the mouse keys (in combination with the ‘Ctrl’ key) are pressed.  

  

  

Icon  Meaning  Mouse Tool  

 

  

Rotate (Orbit)  

  

Drag while pressing both ‘Ctrl’ key and the left 

mouse button.  

 
Zoom  

  

Drag while pressing both ‘Ctrl’ key and the 

middle mouse button.  Drag upwards to 

zoom out and downwards to zoom in.  

 
  

Pan  

  

Drag while pressing both ‘Ctrl’ key and the 

right mouse button.  Drag in the direction in 

which you want to pan the design.  

 
Zoom by area  

(select the area to be displayed)    

 Zoom Selection  

(zoom to show selected object)  

only available when an object is selected in 

the graphics panel.  

  

 
  

Zoom to Extents  

(zoom out to display the entire design)  
  

  

  

  

  

  

http://www.zuken.com/cadstar


For more information visit  www.zuken.com/cadstar  

14 
 

 
Re-center  

(pans the display so the selected object  

is at the centre of the screen)  

only available when an object is selected in 

the graphics panel.  

  

  

  

• Experiment with these icons to see how they operate and get used to manipulating the view of the 

design.  You can use these operations in combination with the rendering mode commands (see 

above) to explore different views of the data.  

  

Tip: Use the View Extents icon to bring the entire design back into view in the graphics panel at any  

stage if you get lost!  

  

It is possible to cycle backwards and forwards through previous views of the design using the 

Back and Forward icons on the toolbar.  

  

• When you are satisfied that you are familiar with these operations, perform a View All command then  

chose the Select icon from the 3D Model Toolbar.  

  

  

 

  
  

Note: The 3DConnexion Space Navigator ® is a great alternative 

to using a 2D mouse since provides 6 axis levels of control.  
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  Selecting Objects  

  

Design items can be selected in BML in several ways.  They may be selected individually by clicking on 

them in the graphics panel, multiple objects may be selected at once by drawing a selection rectangle 

around them and items can be selected in the Control Panel (on the left of the Graphics Window), which 

will then be highlighted in the Graphics Panel.  

  

The type(s) of item which will be included in any selection is governed by the current setting of the Selection 

Filters and these are displayed as a row of icons at the bottom of the Graphics Panel.  

  

  

  
  

The name and meaning of each filter is explained in the following table.  

  

Icon  Filter  Description  

 Board  Allows the PCB board itself to be selected  

 Hole  
Allows any holes (representing vias or 

component pins) to be selected  

 Conductive Pattern  
Allows routes/tracks and copper areas to be 

selected  

 Mask Pattern  
This option is not currently relevant for BML – 

please ignore.  

 Symbol  
Allows the silkscreen pattern from within the 

component footprint (if any) to be selected  

 Component  
Allows the components (parts) themselves to 

be selected  

 Restriction Area  

Allows restriction areas included within the 

component footprint to be selected (for 

example, placement shapes)  

  

 

Height  Limitation 

Area  

Allows any height limitation areas defined in 

the design to be selected  

  

 
Mechanical Part  

Allows any mechanical parts (also known as 

‘constraints’) imported into the design to be 

selected  

 Document  
This option is not relevant for BoardModeler 

Lite – please ignore.  

 WCS  
Allows any WCS origins (working coordinate 

system) to be selected  
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 Chassis  
This option is not relevant for BoardModeler 

Lite – please ignore.  

 

Cross probing with CADSTAR  

  

Design items can now be selected using the cross probe feature. This feature can be used at any time 

once both applications are opened.  

In Board Modeler Lite the cross probing function is enabled in the ‘Tools > Options’ dialog ‘Other’ tab.  

  

In CADSTAR the option found on the ‘File > Options > Cross Probing’ tab for ‘Enable selection from 

CADSTAR to Others for single select’ should be enabled.  

  

  

  

Once the option ‘Enable cross probing 

between BML and CADSTAR’ is enabled 

within Board Modeler you will be able to 

select a part, or a route to cross probe.  

  

Cross probing from Board Modeler Lite will 

automatically highlight the selected item 

CADSTAR.   

  

The cross probing is currently limited to only 

parts, routes and copper areas associated to 

a signal.  

  

Note: When Board Modeler Lite is launched 

from the start menu before CADSTAR is 

started the cross probing function will be 

disabled, and a warning message will be 

displayed. When this dialog is shown BML 

will automatically disable the cross probing 

option.  

  

Cross probing will need to be enabled 

manually in BML once CADSTAR has been 

started if you require cross probing to be 

used.  
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Task 3 – Selecting objects  
Try the following examples to get used to the different ways of selecting items within the design.  

  

1. Ensure the Board and Component filters are active (click the icons 

so that they look as though they have been pressed in).  

  

2. Hover a component in the Graphics Panel.  The object changes to 

the Preselect color, in this case yellow.   

  
3. Select a component in the graphics panel using the left mouse 

button.  The selected component will be displayed in the Select’ 

color   

  
  

The Preselect and Select colors can be changed in the Tools>Options [Color] tab dialog.   

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

 

While still holding down the <Shift> key, click on the PCB board 

in an area where there are no components.  The board is also 

added to the selection set.  

Hold down the  < Shift >   key on the keyboard and click on some  

different components.  Notice that they are added to the  

selection set and also drawn in the ‘ Select ’ colo r.   

Now click on the background of the graphics panel where there  

are no design items.  This will clear the current selection. 

  

In the  Control Panel   to the left of the Graphics Panel),  ( 

make sure that the  Parts   tab is displayed and try selecting  

a row of the table (for examp le, the one corresponding to  

J .  The corresponding component will be highlighted in  1) 

the graphics panel in the ‘ Select ’ colo r.   
Click 
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       To select a range of components in the control panel 

(e.g. from R1001 down to R1006), first click on the 

R1001 row then hold down the <Shift> key and click 

on the R1006 row.  All components in-between will 

be selected and highlighted on the display.  

  

  

Note: To sort the parts by ref des, click the <L.M.B.> on 

the column header Ref.  

  

Note: If you select components by clicking on the design in the graphics panel, the corresponding rows in 

the table on the Parts tab are also selected.  

  

 
  

Tip: Change the Rendering of Parts to Transparent or Hide to make is easier to see net objects.   

.   Flip  the design   ( Camera View )   over so that you are looking at the bottom  

of the board (using the Rotate  command)  and add the ‘Conduct ive  

Pattern’  filter to the active set.     

  

  Select any part of the large copper area and notice  

that it is selected along with al l the routing  

patterns.   

  

  Change the Camera view to  B - Side Isometric   

using the  tool bar icon.   

  

  Click the  Select Ne t tool bar icon on the right side  

of the graphics panel.    This will change the  

Control pane l to the [ Nets  tab. ]   

  S elect  the  net  12 V .      

  

     Nets tab    
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In BML select the Options dialog and ensure that on the Other tab that the option ‘Enable cross 

probing between BML to CADSTAR’ is enabled.  

  

Ensure that the CADSTAR design editor window is not minimised and visible.  

  

In CADSTAR ensure that the option to ‘Fit to Selection’ is enabled in the CADSTAR               
 ‘File > Options > Cross Probing’ tab.  

  

  
  

Using the methods described above to select a part locate SW2 in BML and select the component.  

  

The CADSTAR window will now display SW2 and fit the selected component in the available window.  

  

  
  

In CADSTAR select any component, or Route.  

  

In BML the selected item will be highlighted and fitted to the window area.  

  

  

NOTE:  

Data transferred from CADSTAR into the BML design, such as silkscreen and placement outlines, are 

actually part of the component footprint and are not separately selectable items themselves (i.e. they 

cannot be selected by clicking on them in the graphics panel).  However, it is possible to view these items 

and control the visibility of them by turning on or off the relevant layer in BML.  This is explained further in 

the following section.  
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End of Task  
  

 Viewing by Layer  

BoardModeler is a layer based application with 

links to 3D objects. Each Layer is a 3D object in 

itself.  

  

This section will help you to see the layers that are 

imported from the host CAD system.  The 

CADSTAR layer names are listed in the Control 

Panel [Layers] tab.  This tab controls both the 

layer’s visibility and color.  

  

  

  

  

Note: All layer colors can be changed except   

BOARD_FIGURE.  
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Task 4 – Viewing by Layer  
  

1. Click the Layers tab in the Control Panel    

  

2. Change the graphical view using the A-Side Isometric view icon.   

  

3. Tick each box in the View column to make the layers visible as in the image shown below,   

  

Tip: Clicking the View column header button will turn 

all layers on and off simultaneously.  

  

  
  
  
  
  

  

  

  

  

  

  

  

  

4. From the Rendering of parts: drop-down list, 

select the Hide option to hide all the components 

in the design.  You should end up with a screen 

similar to that shown        

  

  The items remaining represent two Height limitation 

areas.  

  

In the Layers tab of the Control Panel you should 

notice that there is a ‘tick’ in the View column for 

every layer listed as shown above.  

  

  

  

5. Experiment by turning or ticking layers on and off 

to see the appearance in the graphical window.  

  

  

6. Clear all the ticks except for the ‘BOARD 

FIGURE’ and ‘Top silk’ layers.  
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7. Try changing the color of Top silk to white. This should be the result... >  

  

 

  

Tip: When creating closed component outlines in the CADSTAR Design Editor, BML will interpret them as 

filled. This is obvious in the image shown above. To avoid this, change any closed shapes in your PCB 

components to Open. They will appear as outlines.  

  

Note: Pads are shown in the image above. Typically, when viewing a silkscreen, pads are not shown. The 

reason for the pads being displayed is that BML takes the default pad diameter and displays it on the silk 

screen. Hint – Take advantage of Pad Code reassignments for the silk screen layer(s).    

  

Note: BML does not display reference designators that are placed on any layers.   

  

  

   

  

End of Task  
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 Task 5 – Controlling the Display of Individual Parts  
By using a combination of the operations we have learned up to now, it is also possible to have different display 

settings for individual components (parts) within the design.  

  

1. From the Control Panel [Layers] tab, select the ‘Default’ option for Rendering of parts.  

  

2. Select power connector, J1 in the design (using any of the methods from above) and press the right  

mouse button.  A pop-up menu will appear.  

  

3. For the moment, ignore all the other options. Using the <R.M.B.> select the View > ‘Transparent  

option and observe the result.   Note: only component J1 is affected.    

 

4. Try assigning different options to other components and note that you can combine different viewing  

options (rendering modes) on a per component basis.   

  

5. Select the Board shape and apply individual rendering mode such as transparent.  

  

6. Select the conductive metal patterns and change the rendering to transparent.  

  
7. Zoom in for a unique viewing perspective  

  

 

End of Task  
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Preparing BML for use with a CADSTAR Layer Stack  

  

  

In order to setup a proper CADSTAR to BML relationship for seamless collaboration, we need to provide 

BML with some information about a default CADSTAR layer stack.  This will allow us to start a design within 

BML, importing a board outline and a placement height limitation area which we can then transfer back to 

CADSTAR.  To do this we need to know which layer should be associated with the height limitation area.  

  

  

In the Project Browser panel, switch to the [EDA I/F] tab.  You 

will see the layers defined which match the layer-stack for the 

current design.  

  

  

Simply select Apply button.  This will update the configuration for 

BML and allow it to use this layer data as a default when a new 

project is created locally within BML (without passing any design 

data from CADSTAR first).  This process will become clear in the 

next section of the tutorial.   
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 Task 6 - Working with Design Data  
Now that we have become familiar with some of the basic operations of BML, we can move on to working 

with design data.  In the next section we will import a board outline into BML – which we have theoretically 

received from the MCAD department, set up the origin of the board and finally load this data into a new 

CADSTAR design which only contains the unplaced components as a result of passing a design forward 

from CADSTAR schematics.  

  

We will also see how placement changes can be made in BML and back-annotated into CADSTAR and 

how we can choose how components are modelled and displayed within BML (from simple extruded ‘boxes’ 

to complex, true 3D models).  

  

Starting a new PCB Design   
  

• If you still have BML running select File>Close>Project. (no need to save it) and Exit,    

  

• Select All Programs>BoardModeler Lite>BoardModeler  from the Windows Start menu to start BML 

again.  

  

  

• Create a new BML project called ‘Tutorial’ by select 

File>New>Project and enter ‘Tutorial’ in the  

Creating new project dialog.  Click [OK]  

  

  

  

  

  

  

  

  

  

The new project will appear in the Project Browser. >  

  

  

  

  

  

  

• In the Project Browser click the Right Mouse Button on the Assembly folder and select New PCB from  

the popup menu.  Enter ‘Tutorial’ again as the name of the PCB.  

  

 

    

    

    

  

  

  

  

  

The Project Browser tree will  

update to show the new contents  

of the project.   

http://www.zuken.com/cadstar


For more information visit  www.zuken.com/cadstar  

26 
 

Importing a Mechanical file  

  

• We will now import the board outline to be used for this 

design from a STEP format file supplied to us by the MCAD 

department.  

  

• Right-click on the Tutorial PCB folder in the Project 

Browser and select Mechanical file>Import... from the 

popup menus.  [Alternatively, ensure the Tutorial PCB 

folder is selected in the Project Browser and then use the 

File >Mechanical file>Import... menu].  

  

  

  

For the next dialog you must tell BM how to support the mechanical file 

that is to be imported.  It is either an Assembly File or a Part File. Since 

the file contains more than one part it is an Assembly file.  >  

  

  

Note: it is important to request this type of data from your MCAD system.  'Assembly' is a STEP 

structuring level and should be understood by most/all MCAD systems that support STEP 

import/export.  

  

• Browse to the C:\BML_Tutorial_Data\BM\_Library\_Constraint folder in the Open dialog and select 

the Mechanical.stp file.  

        

 

  
  

The .STP file is converted to an ACIS file which is native to the 3D kernel being used.  Upon completion, 

a report dialog will be displayed.   If the dialog contains any output, you can open the report to review 

it or else select [Close]  
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The file will be imported and the display should look similar to the image shown.  

  

As you can see, we have not only imported the board outline shape, but six pre-placed components 

and two additional shapes that represent height limitation areas.  

  

 

  

We now need to do a small amount of set-up so that BML knows how to interpret these different items 

of data.  

  

• In the table at the bottom of the Graphics Panel, 

for the first item, set the Element kind to be 

‘Board’.    

  

The Instance name will be automatically set to 

BOARD.    

  

  

  

  

  

http://www.zuken.com/cadstar


For more information visit  www.zuken.com/cadstar  

28 
 

• Set the remaining entries in the table to match those shown in the image below.  

 

Notes:  
  

• For Element kinds that are physical Parts, you enter the corresponding ref des used in the PCB design. 

I.e. J1, J2, SW1 etc.  

  

• The item on Top_Elec_PLACEMENT is set to be an Element kind of Height limit.  The Instance name 

choices are non-electrical placement layers.   

  

Setting the Origin  
  

All that remains is to set the origin for the board.  We are going to locate it at the bottom left-hand corner (seen 

when looking down on the board from directly above).  

  

  

  

  

  

From the 3D Model Toolbar select the Move 

Origin icon.   

  

 This  will  display  the  standard  move  

‘manipulator’ in the Graphics Panel.   

  

  

This could be used to move the origin interactively by 

dragging it.   

In this case, we will specify the exact location where 

we want the origin to be as the intersection of two 

sides of the board.    

  

Note: the pre-placed components and height 

restriction area will not be displayed during this 

process).  

  

  

From the tool bar icon at the bottom of the Graphics 

Panel (tool tip: Ways to specify the origin, select the 

Intersection of two edges option.             >  
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Select the two edges of the board which intersect at the bottom left-hand corner. Once the second  

edge has been selected the Manipulator will be moved to the intersection point.  

  

 
  

Select the tool bar button “Set Board Thickness”.  Here you can select the top and then bottom 

surfaces of the PCB to obtain the board thickness or enter a numeric value in the field available. The 

Value will be displayed in the lower left corner of the graphics window.  

  

  
  

Shown above is the imported parts of the STP Assembly file.  Note the parts listed on the Control 

Panel [Parts] tab.  

  

Save the Project.  

  

  

  

  

  

  

  

  

  

  

    Finally,  select the   bottom icon from the 3D Model t oolbar to accept all the changes  

we have made and ‘register’ this information in the project.    Review the Import result  

dialog and then close it when finished.   
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 Task 7 - Importing BML data into CADSTAR  
We have now prepared the board outline shape with the required 

origin and are ready to export this data for use in CADSTAR 

Design Editor.  

  

  

1. Right-click on the Tutorial PCB folder and select 

CADSTAR>Export... from the pop-up menu.  

  

  

  

2. Set the following paths for the RIF and RINF files in the 

CADSTAR Export dialog and then select [OK]  

  

Please note the following export path and filename (do 

not overwrite the file “Start Placement.frs”)!  

  

C:\BML_Tutorial_Data\CADSTAR\Self Teach\Tutorial.rif C:\BML_Tutorial_Data\CADSTAR\Self 

Teach\Tutorial.frs  

  

Make sure you include the correct file extensions (.rif and .frs) in the names.  

    

3. Select File>Exit and then choose Yes when prompted to save the data and quit BML. If BML was 

started from the Tools menu in CADSTAR you will be now be prompted to reload changes into the 

CADSTAR design.  Select No, and close the design without saving.   

  

  

4. Start CADSTAR and load the ‘Tutorial’ workspace (‘C:\BML_Tutorial_Data\CADSTAR\Self 

Teach\Tutorial.csw’).  The display should look similar to that shown below.  
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5. Select  File>File Import... and set the format to 

be P.R.Editor XR Files.  Use the [Browse] 

button to select the ‘Tutorial.rif’ file from the 

‘C:\BML_Tutorial_Data\CADSTAR\Self 

Teach’ folder.  

  

Do not change any other settings and simply 

select [OK].  

  

  

6. Change the CADSTAR view by performing  

View All to see all available details.  I.e. Select 

[View] tab > View All or hold down the <alt> 

keyboard button and press <F8>.  

  

The board outline and height limitation area 

shapes from BML will be imported into the CADSTAR PCB design.  

  

7. Repeat the same File>File Import. process but this time set the format to be RINF Netlist and use the 

[Browse] button to select the ‘Tutorial.frs’ file from the ‘C:\BML_Tutorial_Data\CADSTAR\Self Teach’ 

folder.  

 

8. The six pre-placed components will be positioned in the correct location on the board per the 

Mechanical.stp file.  Select them and click the <R.M.B..> to Fix them.  
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9. To quickly place the remaining components on the board and for the purposes of this tutorial, import 

the RINF file StartPlacement.frs from the C:\BML_Tutorial_Data\CADSTAR\Self Teach location.   

    

 

Image shown above has layer Top Placement turned off and component names repositioned for clarity.  

  

  

10. Using the same process which we used earlier in the ‘Basic Operations’ section of the tutorial, transfer  

this design to BoardModeler Lite.  This will be used in the next Tutorial section.  

  

Note:  When creating a new PCB outline using Mechanical data files, the CADSTAR PCB design 

containing the parts must already exist.  This process will not import P.R.Editor XR file  into a new 

CADSTAR PCB Design unless a netlist is present containing parts.  

  

  

End of Task  
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Changing How Parts are Displayed in 3D   

Your design in BML may look similar to the image shown if you chose 

to use the Top Placement layer component shapes.  The default 3D 

view of the components on the board is a very simple representation, 

created by extruding the shape drawn on the placement layer (in the 

PCB footprint) in CADSTAR to a defined height.  The height of each 

component can be specified either by adding an attribute to the part 

definition in the CADSTAR library, or by setting the height directly in 

the component footprint.  In this tutorial, we have used the second of 

these two methods.  

  

  

However, this simple representation may not be accurate enough for our needs (for example to check for 

collisions between components and a system case or chassis) and we may have more detailed 3D models 

available for some or all the components we are using in our design.  

  

With BML it is easy to replace the simple representation with a more 

detailed 3D model and also to switch between the different 

representations as required.  

  

Many parts vendors, such as manufacturers of connectors, will 

supply their 3D CAD data on their website in either STEP or ACIS 

file format.  

  

BML offers the 3D Model Wizard in the event locating a proper model 

becomes difficult.   

  

An objective at this stage is to collect the critical 3D part geometries and 

store them in a safe place. This is commonly located in the BM Installed 

DOCUMENT folder.  

  

For this Tutorial we have provided you with some higher details shapes in 

a project structure in place. See “C:\BML_Tutorial_Data\BM\Library”, 

specifically the _Parts_2 folder.  

Shown to the right is a view of the _Parts (Level 2) folder containing a 

small number of 3D Models. >  

  

To preview any model in the library before adding it to the design select the 

View > Preview Window option.  

  

  

  

  

  

  

  

  

Mechanical enclosures for collision checks   

Lowest level of parts detail   

BML Tutorial 3D Parts are stored here.   
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Task 8 - Changing How Parts are Displayed in 3D   
  

 

  

In the dialog that appears, ensure that the 

Library Path field is set to “Level 2” and select 

the Replace button.   

  

Click [Yes] to confirm that the dialog should be closed.  

  

You should now notice that the simple 

representation for the selected component has been replaced by a more 

detailed model.  

  

  

  

  

  
  
  

R epeat the same process with a few more of  
the components in the design.   
  

O nce completed  select one of the components  
with a detailed 3D model and then click the  

>. R.M.B. <   From the pop - up menu select  
Precision level   and the n  Level  1 .   

The   representation for the component has now  
returned to the default, simple representation.   

M ultiple components   can be selected   ( using  
< Shift > +< L.M. B.>   or by  frame selecting   the  
components) and set the precision level for all  
selected components in one oper ation.   

Select one of the slide pot 

components in the design (P1 or P2) 

and click the right mouse button.  

From the assist menu select the 

Replace with Library... option.  
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 It is possible to make the display of the detailed 3D models the default option when the design is passed from 

CADSTAR to BML and we will see that in operation very shortly.  

  

The relationship between the components used in the design and the detailed 3D models is handled 

automatically based on 1 of 4 methods  

  

1. The ‘Reference’ and ‘Alternate’ names defined for the parts used within CADSTAR matches the 

name of the 3D model.  

2. The Part name in CADSTAR matches the name of the 3D Model  

3. A user attributed such as “3D_model” is added in the CADSTAR Part library or just with in the local 

design attributes.  

4. Using an XLS file that can be referenced by BML  

  

  

If we take the diodes (D1001, D1002) as an example, in CADSTAR (using Item Properties) you can see 

that the reference is ‘dio-04500185‘ and the alternate is ‘do35-1016‘.  Based on this, BML will look for a 3D 

model to represent this part with the following name: dio-04500185-do35-1016.sat.  

  

This mapping can be seen on the Parts tab of the Control Panel in BML, in the Library ID column – as 

shown below.  

  

  

   
Control Panel in BML  

   

    

The file name for the 3D model is built by combining the reference name with the alternate name, separated 

by a hyphen. The ‘.sat’ file extension is added automatically.  In the case for the transistor Q2, the alternate 

name is blank, the name of the 3D model simply becomes the CADSTAR reference name (to92.sat).  

  

If you use Windows Explorer and 

navigate  to  the  folder 

 {x}:\BML_ 

Tutorial_Data\BM\_Library\_Parts_2 

you can see the 3D model files used for 

this tutorial design.  

  

Note: For existing CADSTAR 3D users, 

BML provides a very simple and 

straightforward way of converting any 

existing 3D model libraries into a form 

suitable for use with BML]. See  

Appendix - A  

  

  

  

  

  

  

  

  

  

Item properties   window   in CADSTAR   
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Now that we have seen how to change the representation for individual components interactively within  

BML, let’s look at how to have the detailed 3D models displayed by default when the design is passed from 

CADSTAR to BML.  

  

3. Exit from BML (File >Exit) and return to CADSTAR – there is no need to save the project.  

  

  

4. Select Tools>BoardModeler... to pass the design to BML again in the same way as previously –  

but we now need to change the settings on the CADSTAR Import dialog.   

  

Make sure the settings are as shown in the image – specifying that we want to use the representation 

from the BoardModeler library at precision level ‘Level 2’.  

 
  

  

As an alternative to using the combination of the reference 

name and alternate name to form the name of the detailed 

3D models, it is possible to configure BML to use the part 

name.  To use this option, ensure that the relevant 3D 

models are named correctly based on the CADSTAR part 

names (e.g. ‘1N914.sat’) and select the Part name option for 

the Library ID: field on the CADSTAR Import dialog.  

  

  

  

  

  

  

  

  
  
  
  
  
  
  
  
  
  
  
  
  

Note:   Some 3D models are not present in this example.  
This is a good test to find which models are missing or  
need to be reassociated.   

  
  

When the design is loaded into BML the detailed 3D  
models will be used immediately.     

  

You may switch back to the simple pre cision   for  
individual components in exactly the same way as  
described above .   
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Note: Another alternative is to create an Attribute of Components in the CADSTAR Parts Library or within 

the local attributes of the PCB design (Shown below).   For those 3D models specified in the attribute value 

they will automatically be used when the 3D Model Name – Library ID: is set to Attribute.  
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 Task 9 - Moving Parts in 3D and Collision Checking  

Now that we have our design in 3D, we can investigate how to change the component placement by moving 

components in the 3D environment.  During this process we can also perform on-line ‘collision checks’ to 

make sure that we are not causing errors in the design.  

  

We will also investigate the use of the ‘measure’ functionality to measure sizes and distances and the 

‘clearance’ tool which allows us to identify all objects which lie within a specified clearance distance of a 

selected component or other design item.  

  

Finally, we will see that having changed the component placement, the new component positions are 

backannotated to CADSTAR to update the 2D PCB design.  

  

  

1. Start by selecting capacitor C4 and then choose the ‘Move’ icon 

from the 3D Model Toolbar.  

   

  

You will see movement ‘manipulator’  

appear, at the components origin. >  

  

  

Selecting and dragging on the red, green or blue-coloured 

arrows (if visible) will move the component, but it will be 

constrained to move only in the direction of the axis you have 

chosen (corresponding to the arrow).    

  

  

The component can be rotated by clicking on the blue circular-

shaped arrows located at the top of the manipulator.  The top 

control (with only an arrow at one end of the arc) will rotate the 

component through 180 degrees, whereas the lower control 

(separate arcs with an arrow on each one) will rotate through 

90 degrees.  

  

  

It is possible to disable the grab handles in the Z-axis. (i.e to 

lift items off the board).   This setting is located in the 

Tools>Options[Other] tab.  If you did not select this option, then you 

will also see a third, blue arrow forming the Z-axis part of the 

manipulator  

  

  

 
  

Note: Z-axis movement is not back annotated to CADSTAR as a height change. However it will affect 

the clearance measurements in BML which may not be valid.  
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Before we move the component, select the icon  at the bottom of the graphics panel to Synchronize 

Collision Check.  

  

  

  

Now click and drag on the small black cross with 4 arrows and move the component so that it lies 

somewhere close to another component . Try to collide with it and then release it.  

  

Notice that both of the components have 

turned red and an entry has appeared in 

the  ‘Collision’ table.   

  

  

Correct this error by moving the component (in the same way as before) until it is clear of the collision 

location, or we could simply use the Reset icon (from the bottom of the graphics panel) to 

immediately return it to its original location.  

  

  

Experiment with these controls to see how they work until you are comfortable with their operation.  

You can always Reset the component position at any time or use the Undo/Redo icons to step 

backwards and forwards through individual move operations.  Note that you can select multiple 

components (using <Shift>’ <click> etc.) and move them together in one operation.  

  

Locate and move C1001.  Any small movements of the component should result in a collision check  

error with the height limitation area rule.  Attempt to correct the placement of these components.   

  
  

Components may be swapped to the other side of the board using the Reverse icon (located at the 

bottom of the graphics panel) and component positions and rotations can be set by typing in exact 

values in the input fields (again, at the bottom of the graphics panel).  

 

As you move the components, you should notice that for every ‘collision’ error that you cause, a line 

will be added into the Collision table below the graphics panel.  If you click on any of these table rows, 

the corresponding items, which are involved in the collision, will be highlighted on the display.  

  

 

  

  

  

  

  
  

  

  

  

  

  

  

  

Click 

  
  

Click 
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Once you have finished experimenting and you have a modified placement, save the project and exit  

from BML to go back to CADSTAR Design Editor.  

  

  

  

You will be asked to verify that you want to re-build the 

results of the changes made in BML, back into 

CADSTAR.  Select Yes, and notice that the placement 

of the components in CADSTAR has changed to match 

that set up in BML.  

  

  

  

  

Task 10 - Measuring Distances and Checking Clearances  
In this task we will investigate the use of the ‘measure’ functionality to measure sizes and distances and 

the‘clearance’ tool which allows us to identify all objects which lie within a specified clearance distance of a 

selected component or other design item.  

  

1. Load the ‘3D Enclosure’ workspace into CADSTAR Design Editor (‘3D Enclosure.csw’ 

from the ‘C:\BML_Tutorial_Data\CADSTAR\Self Teach’ folder).  

  

2. Transfer this design to BML in the usual way – select the option to use the detailed 3D 

models in the CADSTAR Import dialog (set the Precision level option to “Level 2”). 

Also set the Import Netlist options to import tracks and copper in 3D.   

  

3. Zoom/rotate the display onto the two testpoint 

components, SP1 and SP2.  

  

4. Select the PCB> Verification>Measure Distance tool to 

perform a measurement of the distance between SP1 and 

SP2 by selecting the face on each part closest to each 

other.  Alternatively you may select the Measure tool from 

the 3D model toolbar.  

  
The minimum distance between the two components is 

measured, an entry is added to the Measure table (below 

the graphics panel) and a red line is drawn on the display to indicate 

this minimum distance.  

  

  

  

.   To make a finer   detailed   identificati on of the colliding  
surfaces, c lick the Collision item row in question,    then  
c lick the < R.M.B. >  and select  Detailed Highlight     
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If you change the view of the display (zoom, rotate, etc.) then simply clicking on the entry in the table will 

draw the measurement line again.  If you have multiples entries in the Measure table, then clicking on the 

required table row will show the corresponding measurement line.  

  

If we do not want to simply know the minimum distance between objects, but perhaps the distance between 

two specific points or surfaces on the  

 

the face (notice that it will highlight individually).  

  

  

The distance between these two faces is measured and shown on the display and in an entry in the 

Measure table.   

  

 

With the Level for shape option set to “Geometry”, it is possible to measure distances between different 

points on the same component in addition to distances between components.    

  

8. Continue to experiment with the Measure tool to become familiar with the operation.  

  

  

Using the Clearance tool.    

  

9. Switch to a top view of the board so it is easy to see the measurements.   

  

  

10. Turn off the Board Filter to eliminate any unnecessary selections.  

  

  

  

  

  

  

components ,   then we can also use the Measure  

tool to do this.   

  

5.   Select the Level for shape icon  
( at the bottom of the graphicsl  
panel) and set   the value to  
“Geometry”   
  
  

6.   Now select the face shown, towards the top of  
the first testpoint component.   
  
  

7.   Rotate the display so that you can see the  
parallel face on the second testpoint and select  
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11.   Select the Clearance   Check   icon from the 3D mode l toolbar and select  component SP 
 In the design  

1 

From the toolbar at the bottom of the  
graphics window, select the ‘min’ icon.  This  
will measure the distance from SP  to the  1 
next nearest component   –   or in other words,  
the minimum clearance .  In this case,  
component   R1 .       

  

Click 
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The distance is shown as before with the red measure line on the graphics display and an entry is 

added into the Clearance table.  

 
  

For each object identified, a row will be added to the Clearance table.  In this example case there 

should be 2 rows in the table.    

  

10. Click on each row in turn to see the corresponding red measure line displayed on the design.  

  

 

11. Continue to experiment the Measure and Clearance tools until you are comfortable with their operation.   

  

  

12. Choose the Select icon from the 3D model toolbar, or press the Esc key on the keyboard to cancel  

the Measure or Clearance tool and switch back to the 3D isometric view.  

  

  

  

End of Task  

    

  
  

9.   Now, ensure that SP1   is still selecte d, and enter a value of “150.0”  
into the Clearance field.  This time select the ‘Val’ icon and BML will  
find all components (or other objects) which are closer than this  
specified clearance distance   to component SP 1.   

Click 
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 Task 11 - Replacing the Board Outline  
  

Even after the PCB design has progressed to an advanced stage (e.g. placed and routed), it may still be 

found necessary to change the shape of the board (for example, to accommodate more components or to 

fit the PCB into a modified casing, etc.).  

  

This can be achieved very simply within BML and the new board outline shape can be back-annotated to 

CADSTAR Design Editor to update the 2D design.  

  

We can see how that is done in the following operations.  

  

  

1. Adjust the display of the design to show it as a Top view.  

 
  

  
If we were to jump ahead and import the 3D case enclosures for 

this project, we would find that the board outline collides with the 

bottom case once it was aligned properly.  This can seen in the 

image to the right where the collision intersection has been Detail 

Highlighted.  The same collision occurs on the right opposing 

side of the PCB.  

  
For this step we will reassociate a new corrected PCB outline that 

addresses this fit issue.   
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2. From the Main menu, select the PCB >Substrate >Associate board... function.  In the file window, 

browse to the ‘C:\BML_Tutorial_Data\CADSTAR\Self Teach’ folder and select the file called  

‘modifiedboardoutline.stp’.  

    

 
The new board shape will be imported and will replace the 

original one.  The display should now look like this.   

  

 
  

Note: The new modified board outline only addresses the physical change to the board shape.  This will 

not compensate for other layers such as Top_Elec and Bottom_Elec where copper polygon areas have 

been generated.  These copper areas will have to updated using the CADSTAR Design Editor or 

P.R.Editor to conform to the new modified board shape.  

  

  

  

BML will warn that a board outline is already  
associated with the design and ask for  
confirmation that it should be replaced.  Select  
OK   from this dialog.   
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3. Save the project and exit from BML, returning to CADSTAR Design Editor.  You will be prompted to 

import the design changes from BML.  Select OK from the dialog.  The modified board outline is 

imported into the PCB design.  

  

  

 
  

     Before             After  

  

  

As simple as this task is, it is not always easy to re-align a new board shape.  In most real world cases the 

board shape is coming from the master MCAD design where the origin is placed somewhere other than 

what was translated from CADSTAR. In this tutorial it is easy to visualize since both Board shapes were 

aligned using the same WCS or Origin.   

  

Tip:  Import the replacement board shape as a temporary constraint shape for initial inspection. If the New 

MCAD board shape does not align with the one imported from CADSTAR, it is recommended that it be 

returned to the MCAD user for adjustment.   

  

Tip: BML will allow you to create a 3D Library part where the new board shape can be imported and aligned 

in the desired orientation. Once aligned it can be exported as .STP file and then associated to replace the 

original Board shape.  

  

  

End of Task  
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Adding Mechanical Enclosures  

  

The ability to import a true 3D enclosure is the ultimate comparison using the PCB Designers placement 

scheme  

  

In this section we will go through the 

process of importing a mechanical 

enclosure  (or  ‘constraint’ 

 in  BML terminology) into the 

design, correctly positioning it relative to 

the electronic data (i.e. the PCB) and 

running collision checks to make sure 

the board and the components fit in the 

case correctly.  

  

In an earlier section we used the on-line 

collision checking function which is 

provided as part of the Move command.  

That approach could be used just as well 

here, but to explore more of BML’s 

functionality, we will use the batch 

Collision check option this time.  

  

We will use the Align tool to locate the imported mechanical data in the correct position in relation to the 

PCB data.  

  

Unfortunately, it is not common for PCB Design and MCAD design to have a coincidental origin.  This is 

one area in the world of advanced EM collaboration that is still evolving.  However, with BML we can stream 

line the process and still save a lot time.  

  

Importing an enclosure can be made easier by first placing an additional ‘local’ origin (a WCS or ‘working 

co-ordinate system’) on the BML PCB design. This is not strictly necessary in this case and we could 

achieve the alignment operation without the additional WCS, but in a more complex situation it is a method 

that may simplify things considerably.  
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 Task 12 – Adding Mechanical Enclosures  
  

Before we actually import the enclosure, we are going to add an additional, ‘local’ origin to the board, which 

will help us in the alignment process.  Make sure that the ‘Board’ and ‘Mechanical part’ selection filters are 

active before we start.  

  

 
  

1. Identify the hole in the board nearest to component  P2 (in the bottom left corner when looking from 

the top of the board).  Flip the board over so that you are looking at this hole in the bottom of the board.  

  

 
  

  

Note: only three layers are being displayed as a means of less clutter  

  

  

2. Optional Step - Either select the Add WCS icon from the 3D Model toolbar or select the PCB> Add 

WCS menu option.  

  

From the icon at the bottom left of the graphics panel make sure that the 

option is set to ‘center of arc’ and then select the edge of the hole on the 

bottom surface of the board.  

  
A pale-coloured orgin marker will be drawn at the position where the WCS will be added.  In this case, it should 

be at the centre of the hole.   If the z-axis in pointing in the opposite direction to the one we want select the icon 

at the bottom of the graphics panel to reverse the direction of the z-axis.  

  
Complete the operation by confirming that the WCS  

position by selecting the Do operation icon (at the 

panel).   

The WCS will then be drawn in the normal, solid 

red, blue and green colours to show that it has been 

successfully added.  

  

  

  

  

  

  

  

  

  
should be added at  this  
bottom of the graphics  
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3. Optional Step - You can now flip the PCB back again so that it is the correct way up.  Choose the 

Select icon from the 3D model toolbar or press the ‘Esc’ key to cancel the Add WCS command.  

  

  

  

Now we can add the mechanical case to the design and then align it in the correct position.  

  

 

  

4.   Either select the  PCB  Constraint    Add constraint...   
menu option or right - click on the ‘_Constraint’ folder in  
the Project Brow ser and select  Add constraint ....   
  
  

O pen the file browser in the  Add Constraint  
Shape   dialog,  browse  to the   

    

‘ C: \ BML _ T utorial_Data \ BM \ _Library \   
_Constrain t’ folder and select  
‘ c asing_ bottom _earplug .s tp ’.     
  
  
  

BML will then convert this STEP  
format file  into a , ACIS   ‘.sat’ file  
‘ ( Casing_bottom _earplug .s at ’) and  

the dialog will remain displayed  
allowing you to confirm that this file  
should be imported.     
  
  

Select  OK   from the dialog.   
  
  
  

The display should now  
look similar to this (zoom  
out a little if nece ssary).     
  
  

Note:  the lower left corner  
of the Board outline is  
aligned with the PCB board  
mouting boss in the  
Case_bottom.   
  

Had we used the WCS  
descrbed on page 44 the  
case_bottom would have  
aligned perfectly.   
  

Howe ver the purpose of this  
task is practice using the  
Align   function.   
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5. Select the tool bar button for Mechanical part. negative Z-direction. “Constraint”.  

  

  

8. Set the Coordinate system option to be ‘Center of arc’ and rotate the design so that you can see 

inside the case and can see the locating boss where the board is going to sit. See image below for 

reference.  

  

  

  

9. Click on the case once to select it and then click on the face of the locating boss that the bottom of  

the board will be aligned with.  See the image below to make sure you get the correct surface.  

  

  

6.   Use the  Move  function to  push   the part  in the  

Hint : use the manipulator and click the  blue   arrow.   

Tip:  I f  the  blue arrow  is  not v isible, please check  
Tools > Options… > Other > Move/Align “Do not  
allow parts to be moved off the board surface  
in the Z ( - axis)” .   

7.   Select the  Align   tool from the 3D model toolbar  
and  ensure that the Element kind option (at  the  
bottom of the graphics panel) is set to  

  
  
  
  
  

Click 
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10. Now set the Coordinate system option to be ‘Origin of model’ and select the WCS orgin, in the 

middle of the locating hole in the board, that we added earlier. If you chose to not add the WCS 

you may select the Circle used for the hole for the same effect.  

A  preview image will now be shown to indicate where the case will be moved to and a straight line 

is drawn joining the origin point selected on the case with the WCS origin selected – i.e. where the 

select point on the case will end up after the Align operation is complete.  

  

  
  
  
  
  
  
  
  
  
  
  
  
  
  

Click 
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You can now add the top of the case and the rear panel into the design yourself.  The data can be found 

in the file called “casing_top_with_spkr_earplug.stp” and “casing_panel.stp” located in the same folder.    

11.   Select the  Do operation   icon (at the bottom of the graphics panel) to confirm and execute  
the operation.   
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As a hint, set the Coordinate system option to ‘Vertex’ and select appropriate corners on the top and 

bottom of the case to align them together.  

 
  

Tip: set top case as transparent for a better view  

  

12. Select the Align tool from the 3D model toolbar and ensure that the Element kind option (at the  

bottom of the graphics panel) is set to “Constraint”.  
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13. Set the Coordinate system option to be ‘Vertex’ and click on the case lid 

once to select it and then select the corner as shown (a small purple spot 

will appear over the corner when the cursor is in the correct postion).  

  

   

14. Select the corresponding corner on the bottom of the case (a small blue 

dot will be shown) and confirm the alignment with the Do operation icon.    

  

  

  

 

The top of the case will be positioned correctly on top of the bottom section  
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Casing_Top aligned with Casing_Bottom with view of constraints set to transparent.  

  

  

Reminder – You can use <CTRL>-+ <Left, Middle and Right> mouse buttons when performing Align 

or measurement functions to zoom, pan, orbit.  

  

15. Placing the Casing Panel is a bit more challenging.  This panel slides into a shallow groove. Zoom 

into the groove and explore the geometry options.  In the example below using the “Middle Point on 

Edge” option allows for easy selection of an outter corner edge on the panel and the corresponding 

mating inner corner  on the bottom case.  
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16. At this point it would be a good idea to save the project (File>Save>Project).  Once the project has 

been saved with the imported mechanical data in place, then it will remain part of the project even if 

the design is modified within CADSTAR Design Editor and passed forward again to BML.  

   

  

End of Task  

  Once  the   panel has been aligned to the  
c ase edges   you will find that  the hole for  
the power jack  is not aligned.        

  

This instance justifys the use of Board  
Modeler as you will see in the next section.   
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 Task 13 - Running Batch Collision Checks  

  

  

  

  

1. 2. 

Earlier in this tutorial we experimented with component to component collision 

checking. Now that three pieces of mechanical constraints have been entered, we 

can perform a more thorough collision check.  

 Setting the layers shown in the image to the right as visible.  

  

  

 Change the View rendering of the three mechanical constraints to be transparent.  
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 Now we can see if BML will detect problems.  

  

  

3. Select PCB>Collision check>All... from the 

menu and set the ‘Collision Check for All’ dialog 

options as shown.    

  

For now, we are just going to look for collisions 

between the components and the casings as well 

as the components to other components.  

  

  

  

  

4. Select the [Start check] button. All the items which are in error (the two components and the case 

itself) will be highlighted in red on the display and there will be an entry added to the Collision table for 

each individual error.  
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Shortly, depending on the speed of your computer, you will see the items that have been identified as 

Collisions on the Collision tab.  

  

The first error (shown in the image above identifies 

R1002 to R1006.  

  

5. Click on the line number 1, Click the <R.M.B.> and 

select Detail highlight,  

  

The two parts appear to intersect each other. This is 

obviously a problem based on the 3D Model used 

for these component reference shapes.  

  

If you wish to adjust the placement to correct the 

collision, please do so.  Note that the routing of the 

copper will not be corrected automatically.   

  

  

6. Click on lines 2 and 3 of the collision report details. They appear to be similar to line 1.   
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7. Click on the error – J1 to Casing Panel then click the 

<R.M.B.> and select Detail highlight.  

  

Depending on how you aligned the panel with the 

Casing_Bottom you may get 1 of 2 results in error.  

  

  

1. The panel maybe colliding / intersecting with 

J1.  

  

2. The panel maybe touching J1 where two 

surfaces share the same space hence no  

  

  

   If you wish to adjust the 

placement of the panel slightly to correct the 

collision, please do so.  

  

   You may also choose to add a comment to the collision details. It will be retained with the project.  

  

  

 

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

8. Click on the line for an interesting error pertaining RL1. You will have rotate the camera view to the left 

side view. Here the leads from RL1 are intersecting the Case_Bottom constraint.  BML offers a solution 

for this which will be discussed in the next task, called Trim Leads.  

  

  

  

  

  

  

  

  

  

  

t rue intersection.  If so you may receive the  

following message.   
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9. Click on the error related to C1001 to the Casing_Top constraint.  This error is quite visible as it should 

have been caught earlier in the design process since the component position violated the Height 

Limitation area that exists.  

  

  

It is possible to combine all or any subset of the checks at the same time, as required.  You can also use 

the Measure and Clearance tools to check distances between the components or board and the 

mechanical case.  

  

The batch collision check can also be limited to selected objects – rather than the whole design.  Simply 

select the objects which you wish to check and use the PCB>Collision check>Selected Data command.   

  

  

10. The last step in this task is to adjust the part placement using your BML skills.  Once you have resolved 

the errors to your satisfaction, save the project.  You may also exit BML and allow the changes to be 

rebuilt into the CADSTAR PCB Design.  

  

Note: Many critical parts have been “Fixed” in this design.  You may change the status from fixed to unfixed 

by accessing the [Parts] tab on the control panel. I.e. Unfix J1 before adjusting its placement.   

  

  

  

  

End of Task  

  

  

  

  

  

 

 

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

RL1   
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 Task 14 - Trimming Through Hole Part leads  
   When importing 3D models from vendors or using the 3D Part model wizard, it may be necessary to alter 

through hole part lead lengths to replicate the final assembly length.  

      

  

Do not worry about lead lengths 

during the creation stage.  Long 

leaded part models can be trimmed 

to fit once they are in place.   

  

    

The use of this functionality is 

based on the proper identification of 

the geometries within a model.   

BML acknowledges pins and their 

various types such as Through hole 

leads.  

  
  
  
  

1. Select part RL1.  As we noted in the previous task it’s leads were colliding with the bottom case  

constraint.  Click the <R.M.B.> and select Open Selected Model.  

  

  

2. With the model open it a new graphics 

window expand the tree view of the 

model on the [Geometry] tab located 

on the control panel.  

  

  

3. Click in one of them to select the 

corresponding body in the graphics 

window.  

  

  

  

  

  

  

  

  

  

4. Select the [3D model] tab. From this 

tab Pin numbers can be assigned to 

bodies as well as declaring them as 

Lead.  

  

This preview of the 3D Model editor is 

important as it will be used when 

creating detailed models  
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5. Close the 3D Model window and return to the PCB window  

  

  

6. Select PCB>Utilities>Trim leads of parts  

  

Enter a Default Protrude length of “30” (th)   

  

Note: Select only the desired parts 

(Hook) you want trim leads to apply  

  

Click the [OK] button.  

  
  
  
  
  
  
  
  
  
  
  

  

  

  

  

The result is a modified local instance of the 3D part model assigned to the parts in the PCB design.  

  

 
  
Note: The actual library model is not altered. To return the part to its original state, simply use the  

“Replace with Library” function.  

  
  

End of Task  

  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  

http://www.zuken.com/cadstar


For more information visit  www.zuken.com/cadstar  

64 
 

Creating Detailed 3D Part Models  

Acquiring 3D part models can be very time consuming, especially when electronic parts manufactures do 

not provide 3D models for download via their web sites.  However, it is worth the search and even to contact 

the Vendor for the actually 3D CAD model.  

  

In the event of a failed WEB search, BoardModeler Lite provides a 3D component wizard which allows 

detailed 3D representations of the components in your designs to be created quickly and easily – there is 

no need to rely on a separate M-CAD department to supply this data.  In fact, this application can be used 

by the M-CAD department to help with the critical parts selection process.  

  

function.   

  

  

  

  

  

  

  

  

  

In BML this feature is referred to   as   the  Create Part Model   
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Note: This is a user selectable option during the installation of BoardModeler Lite and must be installed for 

this section.  

  

  

 Task 15 - Creating Detailed 3D Part Models  
  

In this task you will learn how to use the Create Part Model function to generate detailed 3D models and we 

will also consider the additional steps you may need to perform to prepare the models for use with your 

CADSTAR designs inside BML.  

  

This operation is part of the library management for BML and as such can be performed without any other 

project data being loaded in the application.    

  

So to begin this section, if you already have BML running close any open projects (File / Close / Project)   
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.  

  

  

  

  

  

1.   S tart BML from the Windows  Start   menu or desktop icon    

2.   In the pr oject browser, switch to the   Library   tab.  You should see  

a display similar to that shown     

  
3.   Start the  Create Part Model   function either by selecting the  

Library / Create part model…   menu option or by selecting the  

Create part model…   option from the RMB me nu on one of  the six  

library folders (_Parts (Level  1 )   to _Parts   Level  ( 6) .  We have  

chosen to use _Parts   3) ( Level    for this example.   

  

  

  

  

  

  

4.   The Create Part Model  

dialo g will be displayed as  

shown    
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Whichever method is used, after making a selection the remainder of the dialog will be populated with 

results of the available templates for the selected part and package types.  For example, if we select 

‘168’ from the Pin Count list, the number of different options presented in the table will be limited to 

only 5 entries.  

  

  

  

  

  

  

  
  

5.   First select the drop - down list in  the top left of the dialog labelled Part  

type.  This allows us to select the type of part we wish to create a  

detailed model for (e.g. capacitor, resistor, IC, diode, etc., etc.).   

  

For this example, select ‘IC’ from the list.   

  

  

Having select ed   the part typ e, we can now go on and specify the  

particular  package type that we require.   

  

  

6.   Select the Package type drop - down list and select ‘QFP’ from the list of  

package types.   

  

As an alternative to cho o sing the package type from this list, select  

the Catalog button and  choose   the required package type fr om the  

images shown.   

  

  

  

  

  

  

  

  

  

It is possible to filter the search  

results further by selecting a  

specific number of pins from the  

Pin  count  option.   
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The search results presented correspond to the number of standard templates for the selected package that 

the Create Part Model wizard has defined.  

  

The columns in the dimension associations table (with headings A, A1, A2, D etc.) correspond to the values 

for the specific dimensions shown in the graphics window in the bottom left of the dialog.  If one of the rows 

in this tables gives the correct sizes required for the package, then you can simply select the desired row.  

  

 

Note: Units in the examples shown above are displayed in millemeters.  
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However, if none of these standard sizes matches your 

requirement, it is possible to specify custom sizes for the 

dimensions in the panel at the bottom right of the dialog.  

  

  

Simply enter the required sizes in the table.  Note that you will 

need to make sure all the dimensions for the package are 

consistent  and  do  not  conflict  with  each 

 other.  

  

If you need to enlarge the image in the graphics panel to see 

all the 

dimensions 

clearly, use the ‘Size of figure’ slider at the bottom of 

the window.  

  

  

7. For the purpose of this example, select one of the templates from 

the Search result table.  

  

  

8. Accept the default model name and libray folder 

name shown in the dialog and select the [Compile] 

button.  

  

  

  

  

BML will compile the 3D model for the selected 

package, using any customized dimension values 

and pin count, and confirm successful completion.  

  

  

  

9. Exit the Create part model dialog with the Close 

button and open the relevant folder in the Library tab 

of the Project Browser. You will see that the 3D 

model has been created and added to the library.  

  

  

10. Select the new model in the _Parts (Level 3) folder 

in the Library tab and from the RMB menu select the 

Open Library model option.  The new model will be 

opened and displayed in the Library Model editor 

graphics window.  

  

As you can see, it is very easy to quickly create 

complex 3D models and add them to the BML 

library!  
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11. Finally, select File/Close/Library model from the main menu to exit 

from the 3D Library model editor.  

  

  

End of Task  

 Task 16 - Modifying Detailed 3D Part Models  
  

In this task you will repeat the steps of Task 15 to explore the Create Part Model wizard in more detail and 

try generating detailed 3D models for different types of component packages.  

  

Now that we know how to create detailed 3D models, we can look at the extra steps we may need to 

perform to make those models ready for use in BML to represent the components in your CADSTAR 

designs.    

  

In order for the models to be useful, we need to make sure that the position of the origin and the orientation 

of the component match between the definition of the 2D footprint in the CADSTAR library and the definition 

of the 3D model in the BML library.  

  

So, let’s create an alternative representation for one of the components in our tutorial design and see how 

to set up the required configuration (the 1N914 part).    

  

By referencing the datasheet information below for this part and the existing CADSTAR PCB design, we 

can determine that we need to create a model with the following basic dimensions:  

  

Body diameter  =    80 thou Body 

length  =  200 thou Pin pitch   =  400 

thou Lead diameter =    20 thou  

  

1. Start off by making sure that you have BML running with the BasicOperations project loaded (transfer 

the design from CADSTAR  
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to BML if necessary).    

2.   Switch to the Library tab in  
the Project Browser in  
BML, select the  _Parts   
( Level  5 )   folder and from  
the  < R . M . B . >   menu select  
the Create Part model…  
menu option to launch the  
wizard as before.   
  

3.   Select a part type of ‘Diode’  

and a package type of  

‘General(Axial)’.     

`   

The Search result table will  

be populated with a range  

of  possible  package  

templates .   

  

Since there is no template  

matching the specification,  

w e  can   select   a  model  

template  where the d iode  

body diameter is 200 thou.      
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We can quickly see that the rest of the dimensions 

do not exactly match the sizes we want to use, so 

we need to edit the template and create a custom 

package.  

  

4. Enter the custom dimensions in the dialog so that 

they match the values shown in the adjacent 

image. >  

  

  

5. Set the Model name and Library folder so that 

they are also as shown in the image, then select 

the Compile button.  

  

  

  

  

  

  

6. In the same way as before, open the newly  

created 3D model in the 3D Library editor window.  

The result should be similar to that shown below.  

  

  

  

  

  

  

  

  

  

  

7. Now select the Move 

origin    icon from the 3D model  

toolbar to see where the origin is currently 

positioned.  As you can see, it is in the centre of 

the component body, not at pin 1 where we need 

it to be.  

  

We now know where to align the origin to make it 

match with the 2D footprint origin defined in the 

CADSTAR library.  

To help with this alignment we will superimpose a 

‘part guide’ onto the 3D model window.  

  

8. Switch to the Assembly tab in the Project Browser.  

Make sure the _Parts folder is expanded and 

select the diode (dio04500185-do35-1016) from 

the list.   
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9. Now, from the RMB menu select Load part guide.  

Select OK to accept the default footprint from the next 

dialog that is displayed.  

  

  

  

Notice that two numbered, origin symbols have been 

added to the display, marking the position of the 

component terminal positions as defined in the 

CADSTAR footprint.  >  

  

  

  

  

  

  

  

  

10. Use the Front display icon to switch the view to a 2D 

view of the front of the component.  >  

  

  

  

  

  

11. Select the Move origin  icon again so that we can re-position the origin in the correct location.  

  

Since we know that the pin-pitch of the component in our design is 400 thou and the orign is currently 

positioned at the centre of the component, we know we need to move the origin by 200 thou in the x-axis 

direction.    

  

We could simply repositon the origin by dragging on the red arrow in the Move ‘manipulator’, but to position 

it in exactly the correct location, the easiest way is to type the required shift into the number field at the 

bottom of the graphics window.    

  

  

12. Enter ‘200’ in x-axis box and press the Enter key. The display 

will be updated to show the new origin location.  

  

  

   
  

(Isometric view shown)  

  

  

  

13. Save the modified 3D model (File / Save / 3D model) and 

exit from the 3D Library editor back to the main project 

window.  
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‘Replace with library…’ option.  

14.   Adjust the graphics display so that you can see the two  
diodes (D1 001 , D 100 2)  in the design.   

15.   Select both diodes and from the RMB menu select the  
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16. The Replace part with library shape dialog will be displayed.  Set the Library folder to ‘Level 5’ and  

select the Replace button and then Close the dialog   

  

The original models have now been replaced with the new ones we have created.  

  

 
  

You should now be able to create suitable 3D models to match the components used in your own designs 

and use them to replace the simple, extruded models generated by BML.  

  

End of Task  

Task 17 - Setting colors in 3D models  
  

After creating 3D models using the Create Part Model wizard, it is possible to change the colors which are 

used in the models.  The following steps demonstrate how to achieve this.  

  

1. Open the model of the diode we created earlier in the 

tutorial into the Library Model editor.  

  

  

  

  

  

  

  

  

2. Make sure that the Level for shape option (at the 

bottom of the graphics window) is set to ‘Body’ 

and then click on the part of the model for which 

you would like to set 

the colour.   

  

  

  

  

3. From the Library model menu, select the Set body color… option.  This will 

open a colour picker dialog which will allow you to select the desired colour for 

the body.  
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4. Repeat 

the process as 

required to change 

the colour(s) of 

other parts of the 

model, before 

saving it ( File / 

Save / Library 

model) back to the 

library.  

  

  

This completes the interactive exercises which comprise the BoardModeler Lite tutorial.  

  

Appendix  

   
  

Preparing CADSTAR designs for use with BoardModeler Lite  
  

Please note:  The remaining sections in this document are not intended to be part of the tutorial (i.e. you 

do not need to follow any further steps or complete tasks).  The information is presented as a reference to 

assist in your future use of BML, when setting up your own designs for transfer from CADSTAR to 3D.  

  

For a CADSTAR PCB design to be used successfully with BML, to obtain a meaningful representation in 

3D, we need to ensure that suitable information is available within the CADSTAR data to define the 

following:  

  

• The height of the components mounted on the board  

• The outline shape used by BML to create the simple representation of the components in 3D.  This 

shape is ‘extruded’ to the specified height  

• The correct thickness and material for the electrical layers in the design  

• Construction layers (e.g. laminate and pre-preg) to define the correct layer-stack for the design and a  

material and thickness for these layers  

  

In addition to the above, in order to pass a CADSTAR PCB design to BML, there must be a board outline 

defined in the data – otherwise the transfer will fail.  This board outline can easily be replaced later within 

BML if required.  

  

  
  
  

Specifying the Component Height  
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The component height may be passed to BML in a number of ways, as follows:  

  

• As an attribute defined in the parts library with the default name of ‘height’  

• As an attribute defined in the parts library with a user-defined name (e.g. ‘Height/Inches’)  

• As a component property specified in each footprint symbol  

  

If a component has height information specified as both an attribute on the part and as a property in the 

footprint, BML will use the specified attribute in preference to the setting in the component footprint.  The 

height in the component footprint will only be used if there is no height attribute present.  

  

Please also note that as attribute names in CADSTAR are not case-sensitive, attribute names such as 

‘height’, ‘Height’ and ‘HEIGHT’ would all be considered to be the same attribute.  You may still use 

capitalisation of any letters to assist with readability if required.  
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Specifying Height as a Part Attribute  
  

To specify the height as an attribute requires that the parts library is edited.  First add an attribute definition 

to the library, using either the default name (‘height’) or any other name if preferred.  In the example below 

we have used an attribute called ‘Height/Inches’.  

  

Set the Attribute Usage value to ‘Part Definitions’.  

 

Then for each part required, set the value of the attribute to the correct height for the part.  You may also 

decide to make the attribute ‘read only’ – but this is not necessary for BML to use the information correctly.  

  

The height may be specified together with a suitable units specified (e.g. 300thou in the example below), 

or if no units are specified, the value will be interpreted in whatever the current design units are.  
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If you have used the default attribute name ‘height’, then this will be used automatically by BML and no 

changes to the settings in the CADSTAR Import dialog are required (simply leave the Height attribute: 

field empty).  

  

However, if you have decided to use a different attribute name (e.g. ‘Height/Inches’ etc.) then in the 

CADSTAR Import dialog you must specify the name of the attribute which you would like BML to use.  

  

   

Specifying Height in the Component Footprint  
  

The alternative approach is to specify the height as a ‘component property’ in the footprint symbol.  To set 

this up, select the required component in the design and open it for editing (select Edit Component from 

the right mouse button menu or from the main Libraries menu).  

  

  

 

  

  

Once the component has been opened for edit, the height can be set on the Component Properties dialog 

(Design Tab / Properties /Component Properties... ).  Enter the value in the units specified.  You will 

need to re-load the footprint symbol into the design for any changes to be reflected in the design.  
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Specifying the Component Outline Shape  
  

To create the default, simple 3D view of components in the design, BML will use a single shape to create 

a 2D outline, to which it will then add the specified component height (as outlined above), to create the 3D 

representation.  

  

Users may specify the CADSTAR layer name that the Simple 3D shapes can be read from.  I.e. Top  

Placement, top Silk, Top Assembly, etc., on the CADSTAR Import dialog as the design is passed forward 

from CADSTAR to BML.  

  

  

Although this value  cannot   be changed subsequently in  

the design   ( i.e. it can only be modified by editing the  

footprint symbol again) , it can be viewed on the  Item  

Properties   dialog for the component.      
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The image below shows the tutorial design in CADSTAR with only the Top Placement layer visible (since 

there are no components placed on the bottom of the board).  

  

  

 
  

It is possible to use a different layer (other than the placement layer) to define the outline which BML will 

use to generate the simple 3D representation for the components.  This can be achieved under the 

following conditions:  

  

•  There must be a closed shape on the chosen layer to represent the component 

outline. •  The layer chosen must be a non-electrical layer.  

  

   

As an example, let’s assume that we have added a new non-electrical layer called ‘3D Model Shape’ which 

will contain the component outlines which we want BML to use.    

 

To configure BML to use this new layer, we need to specify the correct layer name on the CADSTAR Import 

dialog when the design is passed forward to BML.  
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Note that once the design has been loaded into BML, it is possible to see which layer has been specified 

under Conversion Parameters on the EDA I/F tab of the Project Browser.  
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Specifying a 3D model using an attribute in the CADSTAR Parts Library  
  

It is possible to specify the preferred 3D model 

name to be associated to a CADSTAR Part by 

using an attribute.  

  

Create a new attribute in your CADSTAR Parts 

Library I.E. 3D_Model.   

  

Enter the 3D shape file name that exists in the 

preferred Precision level. I.e. Level 2 of the 

BM/_Library folder structure.   

  

Enter the Attribute name in the empty field in the 

3D Model Name section of the import dialog.  

  

  

  

  

  

  

  

  

  

  

  

  
  
  
  

Adding Construction Layers to the Design Layer-stack  
  

The layer-stack for the design used in this tutorial is only a simple, double-sided board.  Even so, for it to 

be represented correctly in 3D within BML it is necessary to define the core laminate layer and assign it 

the correct thickness.  The same applies to the top and bottom electrical (conductor layers).  The image 

below shows data from the CADSTAR Layers dialog showing the layers and their thicknesses.  
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Materials for Electrical, Construction and Non-Electrical Layers  
  

  

Although BML does not currently use the information 

regarding the actual materials used for each layer, this 

may change in the future and it is good practice to set-up 

the design data so that it is correct. Other tools in the 

CADSTAR suite (e.g. SI Verify) do require this 

information to be specified in order to function correctly.  

  

For non-electrical layers (for example, solder mask 

layers), it should be noted that unless a material is 

assigned to the layer in CADSTAR, the layer thickness 

will not be output into the CPA file and therefore 

would not be available for use within BML.  

  

Materials may be defined or modified by selecting the 

Materials button on the Layers dialog.  If no suitable 

pre-defined material exists in the list, select the Add 

button to add a new one and enter the required 

  

  

  

  

  

  

  

  

You should also set the correct ‘embedding’ for  

the electrical layers. \   
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values on the Material Details dialog.  Any new material definitions added are saved with the CADSTAR 

design.  

  

  

  

Materials need to be given a name and a type (e.g. Construction, Electrical or Non-Electrical depending on 

the type of layer they are to be associated with).  Depending on the type of the material, one or more of the 

Permittivity, Loss Tangent and Resistivity values must be specified.  

  

  

   

Migrating 3D Libraries from CADSTAR 3D to BoardModeler Lite  
  

Users of the previous 3D EM Collaboration tools   

  

• CADSTAR 3D,   

• EM Checker and   

• EM Designer   

  

Companies who have a fully developed 3D Library, can easily migrate the legacy folder structure to be 

BoardModeler (Lite) compliant.  

  

To begin the legacy 3D models migration select Start> Programs  

>BoardModeler Lite>3D Library Migration  

  

  

The adjacent dialog will appear.  

  

  

Select the Source setting depending on the 

previous Zuken 3D applications, library 

folder.  

  

Specify the upper level folder containing 

the 3D symbols  

  

  

A default library folder location will be 

derived from the current BML settings in 

Tools/Options.  

Click the Browse button to redirect the 3D  

Symbols  

  

Choose the precision level folder of where 

the legacy symbols will be copied.  

  

  

  

  

  

Click [Start Copy].  A progress indicator will appear as shown below.  
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Upon completion the legacy folder and symbol name structure will be migrated into the BML folder structure 

as follows;  

  

3D symbol folder names containing the actual symbol are migrated as  

  

       3d Folder name {delimiter} symbol name     > _Parts (Level 4)  

          {Comp name    -     Alternate name}  

  

0.1_Molex_2P   -    Vertical.sab     >   0.1_Molex_2P-Vertical.sat  

  

      3D Symbol name   

          Comp name         {No Alternate}                

   Soic16.sat         > Soic16.sab  
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